biz.neustar.wpm.api
BrowserchromeOptions


public interface BrowserchromeOptions

Options that you can use to customize and configure a ChromeDriver session.

Example for setCapability(java.lang.String key, java.lang.String value)

var options = test.chromeoptions();
options.setCapability("acceptInsecureCerts",true)
var driver = openBrowser("CHROME",options);
var c = driver.getHttpClient();
c.blacklistCommonUrls();
beginTransaction(function() {
	beginStep("Description of Step 1", function() {
		driver.get("http://example.com");
		test.pause(5000);
	});
});

Example for addArguments(java.lang.String arguments)

var options = test.chromeoptions();
options.addArguments("-headless")
var driver = openBrowser("CHROME",options);
var c = driver.getHttpClient();
c.blacklistCommonUrls();
beginTransaction(function() {
  beginStep("Description of Step 1", function() {
    driver.get("https://www.google.com");
		test.pause(5000);
    });
});
Method Summary
 void setCapability(java.lang.String key, java.lang.String value)
          
 ChromeOptions addArguments(java.lang.String arguments)
          
 

Method Detail

setCapability

void setCapability(java.lang.String key,java.lang.Object value)
     Below are the capabilities supported.
     	acceptInsecureCerts: Using the acceptInsecureCerts capability you can bypass, or implicitly trust, 
     	                     TLS certificates that the certificate service in the browser does not 
     	                     trust(Supported for Chrome version greater 79). Values can be true or false.
     	unhandledPromptBehavior: Specifies the behavior of handling unexpected alerts in the driver sessions.
     	                         Values can be accept or dismiss or ignore.
 


addArguments

addArguments(java.lang.String arguments)
	Below are the options supported.
	  -headless: Opens Chrome in headless mode.
	  --incognito: Opens Chrome in incognito mode.
	  --ignore-certificate-errors:  ignores certificate related errors(Supported for Chrome version greater 79).
	  --ssl-version-min=tls1: Specifies the minimum SSL/TLS version to TLS 1.0.
	  --ssl-version-min=tls1.1: Specifies the minimum SSL/TLS version to TLS 1.1.
	  --ssl-version-min=tls1.2: Specifies the minimum SSL/TLS version to TLS 1.2.


Copyright © 2020 Neustar, Inc. All Rights Reserved.